CRAN Package Check Results for Package nloptr

Last updated on 2019-11-19 09:48:50 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2.1 8.43 43.16 51.59 WARN
r-devel-linux-x86_64-debian-gcc 1.2.1 5.01 33.97 38.98 WARN
r-devel-linux-x86_64-fedora-clang 1.2.1 65.08 WARN
r-devel-linux-x86_64-fedora-gcc 1.2.1 61.87 WARN
r-devel-windows-ix86+x86_64 1.2.1 26.00 105.00 131.00 ERROR
r-devel-windows-ix86+x86_64-gcc8 1.2.1 26.00 93.00 119.00 NOTE
r-patched-linux-x86_64 1.2.1 6.02 40.96 46.98 NOTE
r-patched-solaris-x86 1.2.1 152.60 NOTE
r-release-linux-x86_64 1.2.1 6.29 40.90 47.19 NOTE
r-release-windows-ix86+x86_64 1.2.1 18.00 122.00 140.00 ERROR
r-release-osx-x86_64 1.2.1 WARN
r-oldrel-windows-ix86+x86_64 1.2.1 27.00 86.00 113.00 OK
r-oldrel-osx-x86_64 1.2.1 OK

Check Details

Version: 1.2.1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     'config' variable 'CPP' is deprecated
     'config' variable 'CXXCPP' is deprecated
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 1.2.1
Check: line endings in C/C++/Fortran sources/headers
Result: NOTE
    Found the following sources/headers with CR or CRLF line endings:
     inst/include/nloptrAPI.h
    Some Unix compilers require LF line endings.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-ix86+x86_64, r-devel-windows-ix86+x86_64-gcc8, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-windows-ix86+x86_64, r-release-osx-x86_64

Version: 1.2.1
Check: running tests for arch ‘i386’
Result: ERROR
     Running 'test-all.R' [13s]
    Running the tests in 'tests/test-all.R' failed.
    Complete output:
     > if(require("testthat", quietly = TRUE)) {
     + test_check("nloptr")
     + } else {
     + print( "package 'testthat' not available, cannot run unit tests" )
     + }
     Loading required package: nloptr
     -- 1. Failure: Test that solver stops when maxtime is reached. (@test-options-ma
     `x` not equal to `expected`.
     1/1 mismatches
     [1] 1 - 6 == -5
    
     == testthat results ===========================================================
     [ OK: 46 | SKIPPED: 0 | WARNINGS: 10 | FAILED: 1 ]
     1. Failure: Test that solver stops when maxtime is reached. (@test-options-maxtime.R#42)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-devel-windows-ix86+x86_64

Version: 1.2.1
Check: running tests for arch ‘x64’
Result: ERROR
     Running 'test-all.R' [13s]
    Running the tests in 'tests/test-all.R' failed.
    Complete output:
     > if(require("testthat", quietly = TRUE)) {
     + test_check("nloptr")
     + } else {
     + print( "package 'testthat' not available, cannot run unit tests" )
     + }
     Loading required package: nloptr
     -- 1. Failure: Test that solver stops when maxtime is reached. (@test-options-ma
     `x` not equal to `expected`.
     1/1 mismatches
     [1] 1 - 6 == -5
    
     == testthat results ===========================================================
     [ OK: 46 | SKIPPED: 0 | WARNINGS: 10 | FAILED: 1 ]
     1. Failure: Test that solver stops when maxtime is reached. (@test-options-maxtime.R#42)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-devel-windows-ix86+x86_64

Version: 1.2.1
Check: running tests for arch ‘x64’
Result: ERROR
     Running 'test-all.R' [14s]
    Running the tests in 'tests/test-all.R' failed.
    Complete output:
     > if(require("testthat", quietly = TRUE)) {
     + test_check("nloptr")
     + } else {
     + print( "package 'testthat' not available, cannot run unit tests" )
     + }
     Loading required package: nloptr
     -- 1. Failure: Test that solver stops when maxtime is reached. (@test-options-ma
     `x` not equal to `expected`.
     1/1 mismatches
     [1] 1 - 6 == -5
    
     == testthat results ===========================================================
     [ OK: 46 | SKIPPED: 0 | WARNINGS: 10 | FAILED: 1 ]
     1. Failure: Test that solver stops when maxtime is reached. (@test-options-maxtime.R#42)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-release-windows-ix86+x86_64

Version: 1.2.1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     clang-7: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is deprecated [-Wdeprecated]
Flavor: r-release-osx-x86_64