CRAN Package Check Results for Package cplexAPI

Last updated on 2021-10-26 08:09:58 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.4.0 7.26 60.83 68.09 WARN --install=fake --no-examples --no-tests --no-vignettes
r-devel-linux-x86_64-debian-gcc 1.4.0 6.47 47.50 53.97 WARN --install=fake --no-examples --no-tests --no-vignettes
r-devel-windows-x86_64 1.4.0 2.00 8.00 10.00 ERROR
r-devel-windows-x86_64-gcc10-UCRT 1.4.0 ERROR
r-patched-linux-x86_64 1.4.0 7.59 59.80 67.39 WARN --no-examples --no-tests --no-vignettes
r-release-linux-x86_64 1.4.0 7.93 59.16 67.09 WARN --no-examples --no-tests --no-vignettes
r-release-macos-arm64 1.4.0 ERROR
r-release-macos-x86_64 1.4.0 ERROR
r-oldrel-macos-x86_64 1.4.0 ERROR
r-oldrel-windows-ix86+x86_64 1.3.6 2.00 7.00 9.00 ERROR

Check Details

Version: 1.4.0
Flags: --install=fake --no-examples --no-tests --no-vignettes
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:60: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:60: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:60: the top level
     configure.ac:67: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:67: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:67: the top level
     configure.ac:96: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:96: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:96: the top level
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc

Version: 1.4.0
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavors: r-devel-windows-x86_64, r-devel-windows-x86_64-gcc10-UCRT, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 1.4.0
Flags: --no-examples --no-tests --no-vignettes
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:60: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:60: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:60: the top level
     configure.ac:67: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:67: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:67: the top level
     configure.ac:96: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:96: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:96: the top level
Flavors: r-patched-linux-x86_64, r-release-linux-x86_64

Version: 1.3.6
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavor: r-oldrel-windows-ix86+x86_64