CRAN Package Check Results for Package SparseBiplots

Last updated on 2024-07-14 09:51:34 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 4.0.1 10.58 94.70 105.28 OK
r-devel-linux-x86_64-debian-gcc 4.0.1 8.22 70.97 79.19 OK
r-devel-linux-x86_64-fedora-clang 4.0.1 130.63 NOTE
r-devel-linux-x86_64-fedora-gcc 4.0.1 128.90 NOTE
r-devel-windows-x86_64 4.0.1 9.00 84.00 93.00 NOTE
r-patched-linux-x86_64 4.0.1 18.00 91.46 109.46 OK
r-release-linux-x86_64 4.0.1 6.42 91.83 98.25 OK
r-release-macos-arm64 4.0.1 38.00 OK
r-release-macos-x86_64 4.0.1 60.00 OK
r-release-windows-x86_64 4.0.1 9.00 84.00 93.00 OK
r-oldrel-macos-arm64 4.0.1 45.00 OK
r-oldrel-macos-x86_64 4.0.1 82.00 OK
r-oldrel-windows-x86_64 4.0.1 13.00 102.00 115.00 OK

Check Details

Version: 4.0.1
Check: dependencies in R code
Result: NOTE Namespaces in Imports field not imported from: ‘gtable’ ‘rlang’ ‘testthat’ All declared Imports should be used. Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 4.0.1
Check: Rd cross-references
Result: NOTE Found the following Rd file(s) with Rd \link{} targets missing package anchors: ElasticNet_HJBiplot.Rd: spca Plot_Biplot.Rd: ggplot2 Please provide package anchors for all Rd \link{} targets not in the package itself and the base packages. Flavor: r-devel-windows-x86_64