CRAN Package Check Results for Package RAMClustR

Last updated on 2021-10-27 08:56:15 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2.2 14.44 102.75 117.19 OK
r-devel-linux-x86_64-debian-gcc 1.2.2 13.30 77.50 90.80 OK
r-devel-linux-x86_64-fedora-clang 1.2.2 162.42 NOTE
r-devel-linux-x86_64-fedora-gcc 1.2.2 139.68 NOTE
r-devel-windows-x86_64 1.2.2 25.00 126.00 151.00 WARN
r-devel-windows-x86_64-gcc10-UCRT 1.2.2 WARN
r-patched-linux-x86_64 1.2.2 15.68 100.08 115.76 OK
r-release-linux-x86_64 1.2.2 14.15 99.11 113.26 OK
r-release-macos-arm64 1.2.2 NOTE
r-release-macos-x86_64 1.2.2 ERROR
r-release-windows-ix86+x86_64 1.2.2 22.00 126.00 148.00 OK
r-oldrel-macos-x86_64 1.2.2 ERROR
r-oldrel-windows-ix86+x86_64 1.2.2 33.00 126.00 159.00 OK

Check Details

Version: 1.2.2
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘BiocManager’ ‘stringi’ ‘xml2’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-release-macos-arm64

Version: 1.2.2
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     Warning: 'memory.limit()' is no longer supported
Flavors: r-devel-windows-x86_64, r-devel-windows-x86_64-gcc10-UCRT

Version: 1.2.2
Check: package dependencies
Result: ERROR
    Package required but not available: ‘InterpretMSSpectrum’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavors: r-release-macos-x86_64, r-oldrel-macos-x86_64